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Choosing options that affect all of OOo

Choosing options that affect all of OO0

This section covers some of the settings that apply to all the components of OOo and are
particularly important when using Writer. Other general options are discussed in Chapter 5
(Setting Up OpenOffice.org) in the Getting Started guide.

Note The illustrations in this chapter were taken from the English (UK) version of OOo.
The spelling of some terms may be different from those you see on your screen,
especially if you are using the default English (US) version.

1) Click Tools > Options. The list in the left-hand box varies depending on which
component of OOo is open. The illustrations in this chapter show the list as it appears
when Writer is open.

2) Click the + sign by OpenOffice.org in the left-hand section of the Options —
OpenOffice.org dialog box. A list of subsections drops down.

Options - OpenOffice.org

Jser Data ﬁ OpenOffice.org

General

Memary

View

Print This dialogue is used to define general settings when workine
Paths your personal data, the defaults to be used when saving docu.
Colours impartant files. These settings will be saved automatically and
Faonts well,

Security

Appearance

Accessibility

Jawva

COnline Update

Figure 1: OpenOffice.org Options

Note The Back button resets options to the values that were in place when you opened OOo.
This button has the same behavior on all the Options dialog box pages.

User Data options

Because Writer’s revision features mark your changes and comments with the name or initials
stored in the User Data page, you will want to ensure that your name and initials appear there.
To do this:

1) In the Options dialog box, click OpenOffice.org > User Data.

2) Fill in the form on the OpenOffice.org — User Data page (Figure 2) or amend or delete
any existing incorrect information.
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Address
Company
ForenameSurname Initials Peter Hillier-Brook PHE
Street
Postoode,City
Country/Reqgion
Title /Pasition
Tel. (Home M ark)

Fax [ E-mail

[ (0]4 l [ Cancel ] [ Help ] [ Back

Figure 2. Filling in User Data

General options
1) In the Options dialog box, click OpenOffice.org > General.
2) On the OpenOffice.org — General page (Figure 3), the options are as described below.

Help
Tips
Extended tips
Help Agent

Reset Help Agent

Help formatting Default W

Open/Save dialogues
Lise OpenCffice.org dialogues

Document status
[] Printing sets "document modified” status

Year (two digits)
Interpret as years between 1930 /& and 2029

Figure 3. Setting General options for OpenOffice.org

Help - Tips

When Help: Tips are active, one or two words will appear when you hold the cursor over an
icon or field on the main OOo window, without clicking. This setting also affects the display of
notes: if both Help: Tips and Extended Tips are turned off, then you won’t see the contents of
a note when you hold the cursor over the note.
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Help - Extended tips

When Extended tips are active, a brief description of the function of a particular icon or menu
command or a field on a dialog box appears when you hold the cursor over that item.

Help Agent

To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this checkbox. To
restore the default Help Agent behavior, click Reset Help Agent.

Help formatting

High contrast is an operating system setting that changes the system color scheme to improve
readability. To display Help in high contrast (if your computer’s operating system supports
this), choose one of the high-contrast style sheets from the pull-down list. For Windows XP,
the high-contrast style options are as described below.

High-contrast style Visual effect

Default Black text on white background
High Contrast #1 Yellow text on black background
High Contrast #2 Green text on black background
High Contrast Black White text on black background
High Contrast White Black text on white background

Open/Save dialog boxes

To use the standard Open and Save dialog boxes for your operating system, deselect the Use
OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open and Save dialog
boxes supplied with OpenOftfice.org will be used. See Chapter 3 (File Management) in the
Getting Started guide for more about the OOo Open and Save dialog boxes.

Document status

Choose whether printing a document counts as changing the document. If this option is
selected, then the next time you close the document after printing, the print date is recorded in
the document properties as a change and you will be prompted to save the document again,
even if you did not make any other changes.

Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930,
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is
interpreted as 1/1/2020.
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View options
The choices of View options affect the way the document window looks and behaves.
1) In the Options dialog box, click OpenOffice.org > View.

2) On the OpenOffice.org — View page (Figure 4), set the options to suit your personal
preferences. Some options are described below.

User Interface - Scaling

If the text in the help files or on the menus of the OOo user interface is too small or too large,
you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it does
not affect the actual font size of the text in your documents.

Lser Interface 30 wview

Scaling 100%: (& Use OpenGL

Icon size and style ﬂE.hm'SEdDmP'-'t

small || |Default v [[] Use dithering

Use system font for user interface [ ] Object refresh during interaction
Menu

Show icons in menus

Font Lists Mouse
Shaw preview of fonts Mouse positioning
Show font history No automatic positioning v

Middle mouse button

Automatic scrolling »

Figure 4. Choosing View options for the OpenOffice.org applications

User Interface - Icon size and style

The first box specifies the display size of toolbar icons (Automatic, Small, or Large); the
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Gnome on Linux.

User Interface - Use system font for user interface

If you prefer to use the system font (the default font for your computer and operating system)
instead of the font provided by OOo for the user interface, select this checkbox.

User interface - Screen font antialiasing

(Not available in Windows, so not shown in Figure 4.) Select this checkbox to smooth the
screen appearance of text. Enter the smallest font size to apply antialiasing.

Menu - Show icons in menus
Select this option if you want icons as well as words to be visible in menus.
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Font Lists - Show preview of fonts

When you select this option, the font list looks like Figure 5, Left, with the font names shown
as an example of the font; with the checkbox deselected, the font list shows only the font
names, not their formatting (Figure 5, Right). The fonts you will see listed are those that are
installed on your system.

Bitstream Vera Sang| 11 [« |B|J Bitstream Vera Sang| 11
ATArial ” Arial A

. Arial Black
AlArial Black Arial Marrow
ATArial Narrow Arial Unicode MS
AlAvantGarde Bk BT ;_Ltl:;mn _—

| Edm vera -ans

AIA\"GHTGUFUB Md BT Bitstream Vera Sans Mono
AlBakerSignet BT w Bitstream Vera Serif w

Figure 5. (Left) Font list showing preview, (Right) Font list without preview

Font Lists - Show font history

When you select this option, the last five fonts you have assigned to the current document are
displayed at the top of the font list.

3D view - Use OpenGL

Specifies that all 3D graphics from Draw and Impress will be displayed in your system using
OpenGL-capable hardware. If your system does not have OpenGL-capable hardware, this
setting will be ignored.

3D view - Use OpenGL - Optimized output

Select this option for optimized OpenGL output. Disable the optimization in case of graphical
errors of 3D output.

3D view - Use dithering

The Use dithering option uses dithering to display additional colorswhen the computer’s
graphics system offers less than the optimal 16 million (24-bit) colours. Dithering creates the
illusion of new colors and shades by varying the pattern of color pixels. Varying the patterns of
black and white dots, for instance, produces different shades of grey.

Note Internally, 3-D graphics are always created with 16 million colors (24-bit color depth)
and dithering can be used to compensate when fewer actual colors are available.
Without dithering, several bits of color information would be omitted, leading to
significantly reduced image quality.

3D view - Object refresh during interaction

Specifies that if you rotate or move a 3-D object, the full display is rotated or moved and not a
grid frame.

Tip Press Shift+Control+R to restore or refresh the view of the current document.
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Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialog boxes.

Middle mouse button
Defines the function of the middle mouse button.

+ Automatic scrolling — dragging while pressing the middle mouse button shifts the
view.

+ Paste clipboard — pressing the middle mouse button inserts the contents of the
“Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Control+C Select text, table, or object.

Paste content Edit > Paste Control+V Clicking the middle mouse button
pastes at the cursor position. pastes at the mouse pointer position.

Pasting into another No effect on the clipboard The last marked selection is the

document contents. content of the selection clipboard.

Print options

Set the print options to suit your default printer and your most common printing method. You
can change these settings at any time, either through this dialog box or during the printing
process (by clicking the Options button on the Print dialog box).

1) In the Options dialog box, click OpenOffice.org > Print.

2) On the OpenOffice.org — Print page (Figure 6), look at the Printer warnings section
near the bottom.

3) Here you can choose whether to be warned if the paper size or orientation specified in
your document does not match the paper size or orientation available for your printer.
Having these warnings turned on can be quite helpful, particularly if you work with
documents produced by people in other countries where the standard paper size is
different from yours.

Tip If your printouts are coming out incorrectly placed on the page or chopped off at the
top, bottom, or sides or the printer is refusing to print, the most likely cause is page-
size incompatibility.
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Reduce print data
Settings for (%) Printer ) Print to file
Printer
[ ] Reduce transparency [ ] Reduce gradients
[ ] Reduce bitmaps [] convert colours to greyscale

Pririter warnings
Paper size Transparency

Paper orientation

Figure 6. Choosing general printing options to apply to all OOo components

Path options

You can change the location of files associated with, or used by, OpenOffice.org to suit your
working situation. In a Windows system, for example, you might want to store documents by
default somewhere other than My Documents.

1) In the Options dialog, click OpenOffice.org > Paths.

2) To make changes, select an item in the list shown in Figure 7 and click Edit. On the
Select Paths dialog (not shown), add or delete folders as required, and then click OK to
return to the Options dialog. Note that many items have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder
(normally on the user’s personal computer).

Tip You can use the entries in the OpenOffice.org — Paths dialog to compile a list of files,
such as those containing AutoText, that you need to back up or copy to another
computer.
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Temporary files

[il 11T}

Default
Type - |Path
AutoCorrect C:\Documents and Settings\phb\Application DataOpenOffice.
AutoText C:'\Documents and Settings\phb'Application DataOpenCffice.«
Backups D:\Document Files\Open Office 2,0'8ackup
Gallery C:\Documents and Settings\phb\Application DataOpenOffice.
Graphics C:'\Documents and Settings\phb'Application DataOpenCffice.«
My Documents D:\Document Files\OpenOffice_2
Templates C:'\Documents and Settings\phb\Application DataOpenOffice.

C:\DOCUME=~1\phb\LOCALS ~1\{Temp

[
I|'||

i
Im

Figure 7. Viewing the paths of files used by OpenOlffice.org

Color options

In the OpenOftice.org — Colors dialog (Figure 8), you can specify colors to use in OOo
documents. You can select a color from a color table, edit an existing color, or define new
colors. These colors will then be available in color selection palettes in OOo.

Properties

Mame Blue 8

Calour | [ Blue 8

Colour table [T]
EEEEEEEN "

T EErEE | RGE v
EBEEERC | | . = =
EEEEEEEE

EEEEEEEE - ¢ > @
EEEEERENO | s = 2

SEEEEEEE
EEENEEEE
. | ]

EEEEEEC v

a %

Figure 8. Defining colors to use in color palettes in OOo
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Font options

You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system,
OpenOftice.org will substitute fonts for those it does not find. You might prefer to specify a

different font from the one the program chooses.
1) In the Options dialog, click OpenOffice.org > Fonts.
2) On the OpenOffice.org — Fonts dialog (Figure 9):
« Select the Apply Replacement Table checkbox.

- Select or type the name of the font to be replaced in the Font box. (If you do not
have this font on your system, it will not appear in the drop-down list in this box,

so you need to type it in.)
- In the Replace with box, select a suitable font from the drop-down list of fonts
installed on your computer.

3) The checkmark to the right of the Replace with box turns green. Click on this
checkmark. A row of information now appears in the larger box below the input boxes.

Select the checkboxes under Always and Screen.

4) In the bottom section of the dialog, you can change the typeface and size of the font
used to display source code such as HTML and Basic (in macros).

Apply replacement table

Font Replace with
Helvetica | | Arial W %
Always Screen | Font Replace with |
........... W W[ Helvetica Arial A

Font settings for HTML and Basic sources
Fonts Automatic il
Mon-propar tional fonts only

Size 10 hd

Figure 9. Defining a font to be substituted for another font
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Security options

Use the OpenOffice.org — Security page (Figure 10) to choose security options for saving
documents and for opening documents that contain macros.

Security Options
Warn if document contains recorded changes, versions, hidden information ar notes:

[ ] when saving or sending when signing

[ ] When printing [ ] when creating POF files
[ ] Remove personal information on saving
|:| Recommend password protection on saving

Macro security

Adjust the security level for executing macros and specify trusted
macro developers.

File sharing options for this document

[ ] open this document in read-only mode

Figure 10. Choosing security options for opening and saving documents

Security Options section

If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove this information, or you can have OOo remove some
information automatically. Note that (unless removed) much of this information is retained in a
file whether the file is in OpenOffice.org’s default OpenDocument format, or has been saved
to other formats, including PDF.

Remove personal information on saving

Select this checkbox to always remove user data from the file properties when saving the file.
To manually remove personal information from specific documents, clear this checkbox and
then use the Delete button under File > Properties > General.

Macro security

Click the Macro Security button to open the Macro Security dialog, where you can adjust the
security level for executing macros and specify trusted sources.

File sharing options for this document

Select the Open this document in read-only mode checkbox to restrict this document to be
opened in read-only mode only. This option protects the document against accidental changes.
It is still possible to edit a copy of the document and save that copy with the same name as the
original.
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Select the Record changes checkbox to enable recording changes. This is the same as Edit -
Changes — Record. To allow other users of this document to apply changes, but prevent them
from disabling change recording, click the Protect buton and enter a password.

Appearance options

Writing, editing, and page layout are often easier to do when you can see as much as possible
of what's going on in your document. You may wish to make visible such items as text, table,
and section boundaries, and grid lines (see “Grid options” on page 19). In addition, you might
prefer different colors (from OOo0’s defaults) for such items as note indicators or field
shadings.

On the OpenOffice.org — Appearance page (Figure 11), you can specify which items are
visible and the colors used to display various items.

1) In the Options dialog box, click OpenOffice.org > Appearance.

2) To show or hide items such as text boundaries, select or deselect the checkboxes next to
the names of the items.

3) To change the default colors for items, click the down-arrow in the Color setting
column by the name of the item and select a color from the pop-up box.

4) To save your color changes as a color scheme, type a name in the Scheme box and click

Save.
Colour scheme
Scheme OpenOffice.org hd
Custom colours
On |User interface elements |Colour setting |Preview |
Diocument background [ Automatic [+ [
Text boundaries [ automatic | » I:I
Application background [ automatic | w -
Object boundaries [ Automatic | |:|
[+] Table boundaries [ Automatic | |:|
Font colour (] Automatic |« -
Unwisited links [ automatic |« -
Jisited links -Red ................ » -
AntnEnallinarharl — . . [

Figure 11. Showing or hiding text, object, and table boundaries
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Choosing options for loading and saving
documents

You can set the Load/Save options to suit the way you work.

Options - Load/Save

B Load/Save: l
........... s %\\ Load/Save

VBA Properties
Microsoft Office
HTML Compatibility This is where you define general settings for opening and sa+

Figure 12: Load/Save options

General Load/Save options

1) If the Options dialog is not already open, click Tools > Options. Click the + sign to the
left of Load/Save.

2) Choose Load/Save > General.

Most of the choices on the Options — Load/Save — General dialog (Figure 12) are familiar to
users of other office suites. Some items of interest are described below.

Load
Load user-spedfic settings with the document

[ ] Load printer settings with the document
Save
[ ] Edit document properties before saving

[ ] Always create a backup copy

Save AutoRecovery information ever 15 | minutes
[v] Save A ¥ ¥ -

[ ] size optimisation for XML format

Warn when not saving in OpenDocument or default format

Save URLs relative to

File system Internet
Default file format
Document type Always save as
Text document w OpenDocument Text W

Maote: Mot using OpenDocument as the default format may cause formatting or content to be lost.

Figure 13. Choosing Load and Save options

Load user-specific settings with the document

When you save a document, certain settings are saved with it. For example, your choice (in the
options for OO0 Writer) of how to update links is affected by the Load user-specific settings
option. Some settings (printer name, data source linked to the document) are always loaded
with a document, whether or not this checkbox is selected.
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If you select this option, these document settings are overruled by the user-specific settings of
the person who opens it. If you deselect this option, users’ personal settings do not overrule the
settings in the document.

Load printer settings with the document

If this option (new in OOo 2.3) is not selected, the printer settings that are stored with the
document are ignored when you print it using the Print File Directly icon. The default printer
in your system will be used instead.

Edit document properties before saving

When you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).

Save AutoRecovery information every

Note that AutoRecovery in OpenOffice.org overwrites the original file. If you have also
chosen Always create backup copy, the original file then overwrites the backup copy. If you
have this set, recovering your document after a system crash will be easier; but recovering an
earlier version of the document may be harder.

Size optimization for XML format (no pretty printing)

OpenOftice.org documents are XML files. When you select this option, OOo writes the XML
data without indents and line breaks. If you want to be able to read the XML files in a text
editor in a structured form, deselect this option.

Default file format

If you routinely share documents with users of Microsoft Word, you might want to change the
Always save as attribute for text documents in the Standard file format section to one of the
Word document types.

VBA Properties Load/Save options
1) Choose Load/Save > VBA Properties.

2) On the Options — Load/Save — VBA Properties dialog (Figure 14), you can choose
whether to keep any macros in MSOffice documents that are opened in OOo.

- If you choose Save original Basic code, the macros will not work in OOo but are
retained if you save the file into Microsoft Office format.

- If you choose Load Basic code to edit, the changed code is saved in an OOo
document but is not retained if you save into an MSOffice format.
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Microsoft Waord 97,2000
Load Basic code to edit

Save original Basic code again

Microsoft Excel 972000
Load Basic code to edit

Save original Basic code again

Microsoft PowerPoint 97/2000
Load Basic code to edit

Save original Basic code again
Figure 14. Choosing Load/Save VBA Properties

Microsoft Office Load/Save options
1) Choose Load/Save > Microsoft Office.

2) On the Options — Load/Save — Microsoft Office dialog (Figure 15), you can choose
what to do when importing and exporting Microsoft Office OLE objects (linked or
embedded objects or documents such as spreadsheets or equations).

Select the [L] checkboxes to convert Microsoft OLE objects into the corresponding
OpenOftice.org OLE objects when a Microsoft document is loaded into OOo
(mnemonic: “L” for “load”).

Select the [S] checkboxes to convert OpenOffice.org OLE objects into the
corresponding Microsoft OLE objects when a document is saved in a Microsoft format
(mnemonic: “S” for “save”).

[5]

™ MathsType to OpenOffice.org Maths [ OpenOffice.org Maths to MathsType A
||: WinWord to OpenOffice.org Writer [ OpenOffice.org Writer to WinWord
r

Excel to OpenCffice.org Calc f OpenOffice.org Calc to Excel
PowerPoint to OpenOffice.org Impress [ OpenOffice.org Impress to PowerPoint

. =

[L]: Load and convert the object

[5]: Convert and save the object

Figure 15. Choosing Load/Save Microsoft Office options

Setting up Writer 14



Choosing options for loading and saving documents

HTML compatibility Load/Save options

Choices made on the Load/Save — HTML Compatibility dialog (Figure 13) affect HTML pages
imported into OpenOffice.org and those exported from OOo. See HTML documents;
importing/exporting in the Help for more information.

Font sizes Import
Size 1 7 - [] Use English (USA) locale for numbers
Size 7 10 [ ] Import unknown HTML tags as fields
Ignore font settings
Size 3 12 [ - d
Expart
Size 4 14
Metscape Mavigator hd
Size 5 13
[ ] openoffice.org Basic
Size & 24
- Display warning
- Y
e 38 > [ ] Print layout
Copy local graphics to Internet
Character set Western Europe (Windows-121

Figure 16. Choosing HTML compatibility options

Font sizes

Use these fields to define the respective font sizes for the HTML <font size=1> to <font
size=7> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers

When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option (new in OOo 2.3) is not selected, numbers will
be interpreted according to the Language - Locale setting in Tools > Options > Language
Settings > Languages (see page ). If this option is selected, numbers will be interpreted as for
the English (USA) locale.

Import - Import unknown HTML tags as fields

Select this checkbox if you want tags that are not recognized by OOo to be imported as fields.
For an opening tag, an HTML_ON field will be created with the value of the tag name. For a
closing tag, an HTML OFF will be created. These fields will be converted to tags in the
HTML export.

Import - Ignore font settings

Select this checkbox to have OOo ignore all font settings when importing. The fonts that were
defined in the HTML Page Style will be used.

Export

To optimize the HTML export, select a browser or HTML standard from the Export box. If
OpenOffice.org Writer is selected, specific OpenOffice.org Writer instructions are exported.
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Export - OpenOffice.org Basic

Select this checkbox to include OOo Basic macros (scripts) when exporting to HTML format.
You must activate this option before you create the OpenOftice.org Basic macro; otherwise the
script will not be inserted. OpenOffice.org Basic macros must be located in the header of the
HTML document. Once you have created the macro in the OpenOffice.org Basic IDE, it
appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose Tools
> Customize > Events. See Chapter 17 (Getting Started with Macros) for more information.

Export - Display warning

When the OpenOffice.org Basic checkbox (see above) is not selected, the Display warning
checkbox becomes available. If the Display warning checkbox is selected, then when
exporting to HTML a warning is shown that OpenOffice.org Basic macros will be lost.

Export - Print layout
Select this checkbox to export the print layout of the current document as well. It can be read
by OpenOffice.org and by Netscape Navigator and Microsoft Internet Explorer 4.0 and above.

The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents.
These capabilities are only effective if print layout export is activated.

Export - Copy local graphics to Internet

Select this checkbox to automatically upload the embedded pictures to the Internet server
when uploading using FTP.

Export - Character set
Select the appropriate character set for the export.

Choosing options for Writer

Settings chosen on the pages in the OpenOffice.org Writer section of the Options dialog box
determine how your Writer documents look and behave while you are working on them.

1) If the Options dialog box is not already open, click Tools > Options.

2) Click the + sign by OpenOffice.org Writer in the left-hand section of the Options —
OpenOffice.org dialog box. A list of subsections drops down.

General options

The choices on the OpenOffice.org Writer — General page affect the updating of links and
fields, the units used for rulers and other measurements, whether captions are automatically
added to selected objects such as tables or figures, paragraph spacing, and tab stop behavior.
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Options - OpenOffice.org Writer

OpenOffice.org
Load/Save
Language Settings
DpenOffice. org Writer:
General
View
Formatting Aids
Grid
Basic Fonts (Western)
Print
Table
Changes
Compatibility
AutoCaption
Mail Merae E-mail

OEHEEH

g OpenOffice.org Writer

This is where you specfy various settings for text do.
how your text documents are handled in OpenOffice.oro
OpenOffice.org Writer documents. You can also def-
document if you save it afterwards,

Figure 17: OpenOlffice.org Writer Options

1) Choose OpenOffice.org Writer > General on the Options dialog box (Figure 18).

2) Keep in mind the following considerations when selecting options on this page.

pdate
IIpdate links when loading

) Always

(%) On request

) Mever
Settings

Measurement unit

Tab stops

Automatically
Eields
Charts
inch w
0.50" -

Figure 18. Choosing general options for Writer

Update links when loading

Depending on your work patterns, you may not want links to be updated when you load a
document. For example, if your file links to other files on a network, you won’t want those
links to update when you are not connected to the network.

Update fields and charts automatically
You may not want fields or charts to update automatically when you are working, because that

slows down performance.

Settings - Tab stops

The Tab stops setting is also used for the indent distance applied by the Increase Indent and
Decrease Indent buttons on the Formatting Bar.

Setting up Writer
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View options

Two pages of options set the defaults for viewing Writer documents: View and Formatting

Aids (described on page 18).

Choose OpenOffice.org Writer > View on the Options dialog box (Figure 19).

If the items on this page are not self-explanatory, you can easily test their effects in a blank

document.

Choosing options for Writer

This is a good page to check if, for example, you cannot see graphics on the screen or you see
field codes instead of the text or numbers you are expecting.

Guides WView
[ ] Guides while moving Horizontal scrollbar
Simple handles Vertical scrollbar
[ ] Large handles Ruler
Display Horizontal ruler inch
Graphics and objects Vertical ruler imch
Tables [ ] smooth scroll
Drawings and controls
[ ] Field codes
MNotes

Figure 19. Choosing View options for Writer

Formatting Aids options

The display of symbols such as paragraph ends and tabs help you when writing, editing, and
doing page layout. For example, you might want to know if any blank paragraphs or tabs are
included or if any tables or graphics are too wide and intrude into the margins of the page.

On the OpenOffice.org Writer — Formatting Aids page (Figure 20), select the required

checkboxes.

Display of Direct cursor
Faragraph end [ ] pirect cursor
Custom hyphens Insert
Spaces (%) Paragraph alignment
Mon-breaking spaces () Left paragraph margin
Tabs () Tabs
Ereaks () Tabs and spaces
Hidden text Cursor in protected areas
[ Fields: Hidden text Enable
[ ] Fields: Hidden paragraphs

Figure 20. Choosing Formatting Aids options

Setting up Writer
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Note Direct cursor lets you enter text, images, tables, frames, and other objects in any blank
area in your document. OOo inserts blank paragraphs and tabs to position the text or
objects.

This feature is incompatible with rigorous use of styles and can lead to many
formatting oddities, so it should be avoided by professional writers.

The AutoCorrect tool automatically removes empty paragraphs, tabs, and spaces that
are inserted by the direct cursor. If you want to use the direct cursor, then disable the
AutoCorrect tool.

Grid options

Specifying “snap to grid” can be very helpful when you are trying to align several objects such
as graphics or tables. If the grid intervals (subdivisions) are too large, you may find that you do
not have enough control in placing the objects.

On the OpenOffice.org Writer — Grid page (Figure 21), you can choose whether to enable this
feature and what grid intervals to use.

Grid
[ ] snap to arid
[ ] visible grid

Resolution Subdivision
Horizontal 0.40" s Horizontal 1

L

point(s)
Vertical 0.40" i Vertical 1
Synchronise axes

g

paoint(s)

Figure 21. Choosing Grid options

Default fonts

The default fonts specified on the OpenOffice.org Writer — Basic Fonts (Western) page apply
to both Writer documents and HTML (Web) documents.

1) If you want to change the defaults, do so on the OpenOffice.org Writer — Basic Fonts
(Western) page (Figure 22). You can, of course, choose other fonts for use in specific
documents, either by applying direct formatting or by defining and applying styles in
those documents.

2) When choosing fonts on this page you are not limited to single fonts or to the ones
shown in the drop-down list. You can specify a “font family”’as a comma-separated set
of fonts that includes those suitable for Windows, Macintosh, Linux, and other
operating systems. These choices are particularly important in HTML documents.

3) If the document is viewed on a system that does not have the first font specified, it will
use one of the other fonts if that one is available. Otherwise, it will substitute a font that
is available on the system.
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4) Type the list of fonts, separated by commas, in the boxes. If you want these defaults to
apply to the current document only, select that checkbox. The Default button resets the
values on this page to the defaults installed with OpenOffice.org.

Basic fonts (Western)

Font Size
Default Times Mew Roman w12 w
Heading Arial w| |14 v
List Times Mew Roman w| |12 v
Caption Times Mew Roman w 12 w
Index Times MNew Roman v 1 it

[ ] current document only

Figure 22. Choosing default fonts

Print options

On the OpenOffice.org Writer — Print page (Figure 23), you can choose which items are
printed with the document by default. These options are in addition to those on the
OpenOffice.org — Print page (Figure 6).

Some considerations:

« When you are working on drafts and you want to save printer ink or toner, you might
want to deselect some of the items in the Contents section.

« The Print black selection causes color text (but not graphics) to print as black on a
color printer; on a black-and-white printer, this option causes color text to print as solid
black instead of shades of grey (dithered).

+ Contrast Print black with Convert colors to greyscale on the Options —
OpenOffice.org — Print page (Figure 6), which prints all graphics as greyscale on color
printers. (On black-and-white printers, color in graphics normally prints as greyscale.)

- Ifyou are printing double-sided on a non-duplexing printer, you might choose to print
only left or right pages, then turn the stack over and print the other pages.

« Depending on how your printer ejects pages (face up or face down), you might need to
print the pages in reverse order so they stack in the correct order as they are printed.
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Tip You can override any of these defaults when printing a document. Click File > Print,
then click the Options button on the Print dialog box. The Printer Options dialog box
that appears is similar to the one shown in Figure 23.

Contents Pages Motes
Graphics Left pages (¥} None
Tables Right pages ) Motes only
Drawings [ ]reversed () End of document
Controls [ ] Brochure {1 End of page
Background
[ ] Print bladk

Other

Print automatically inserted blank pages
[ ] Create single print jobs
|:| Paper tray from printer settings

Fax “Mone= W

Figure 23. Choosing Print options for Writer

Default table options

On the OpenOffice.org Writer — Table page (Figure 24), you can specify the default table
behavior.

Default Input in tables
Heading Mumber recognition
Fepeat on each page! Mumber format recognition
[ ] Do not =plit Alignment
Border
Keyboard handling
Move cells Insert cell
Row 0,207 it Fuowy 0,20° e
Column 0.20" i Column 1.00" e
Behaviour of rowsfcolumns
) Fixed Changes affect the adjacent area only
) Fixed, proportional Changes affect the entire table
(¥} Variable Changes affect the table size

Figure 24. Choosing default Table options
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Some considerations:

« If most of your tables will require borders or headings, select those checkboxes. If most
of your tables are used for page layout, deselect borders and headings.

«  Number recognition can be very useful if most of your tables contain numerical data;
Writer will recognize dates or currency, for example, and format the numbers
appropriately. However, if you want the numbers to remain as ordinary text, this feature
can be quite irritating, so you will want to deselect it.

« The Keyboard handling section specifies the distances that cells move when you use
keyboard shortcuts to move them and the size of rows and columns inserted using
keyboard shortcuts.

+ The choices in the Behavior of rows/columns section determine the effects that changes
to rows or columns have on adjacent rows or columns and the entire table. You might
need to test these selections to fully understand the effects.

Change tracking options

If you plan to use the change-tracking feature of Writer, use the OpenOffice.org Writer —
Changes page (Figure 25) to choose the way inserted and deleted material is marked, whether
and how attribute changes are marked, and whether and how change bars are marked in the
margins.

Text display
Insertions
Attributes Underlined
[nsert__ |
Colour By author ——
Deletions
Attributes Strikethrough b E ]
Colour By authar »

Changed attributes
Attributes Bold w

Attributes.

Colour By author w

Lines changed

Mark Left margin w| |

Colour I Light red w — —

Figure 25. Choosing options for tracking changes
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Compatibility options

Do you need to import Microsoft Word documents into OOo Writer? If so, you might want to
select some or all of the settings on the OpenOffice.org Writer — Compatibility page (Figure
26). If you are not sure about the effects of these settings, leave them as the defaults provided
by OOo. For information about the settings not described below, see the Help.

Compatibility options for 0202WG-SettingUpWriter PHE_20070918
Options

| Uze printer metrics for document formatting
[ add spacing between paragraphs and tables (in current document)
Add paragraph and table spacing at tops of pages (in current document)
[w Uge OpenOffice.org 1.1 tab stop formatting
[v¥ Do not add leading (exira space) between lines of text
[V Use Openoffice.org 1.1 line spacing
[w add paragraph and table spacing at bottom of table cells
[V Use OpenOffice.org 1. 1 object positioning
[w Usge OpenOffice.org 1. 1 text wrapping around objects
[~ Consider wrapping style when positioning objects
™ Expand word space on lines with manual line breaks in justified paragraphs

[ |ze as Default

Figure 26. Choosing compatibility options

Use printer metrics for document formatting

If this checkbox is selected, the printer specified for the document determines how the
document is formatted for viewing on screen. The line breaks and paragraph breaks you see on
screen match those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a document that will eventually
be printed on a specific printer or when the document is exported to PDF (a process that uses
“Adobe PDF” as the printer).

If this checkbox is not selected, a printer-independent layout will be used for screen display
and printing.

Add spacing between paragraphs and tables (in current document)

In OpenOffice.org Writer, paragraph spacing is defined differently than it is in MS Word
documents. If you have defined spacing between two paragraphs or tables, spacing is also
added in the corresponding MS Word documents.

If this checkbox is selected, MS Word-compatible spacing is added between paragraphs and
tables in OpenOffice.org Writer documents.
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Add paragraph and table spacing at tops of pages (in current
document)

You can define paragraphs to have space appear before (above) them. If this checkbox is
selected, any space above a paragraph will also appear if the paragraph is at the beginning of a
page or column, if the paragraph is positioned on the first page of the document, or after a
manual page break.

If you import an MS Word document, the spaces are automatically added during the
conversion.

Add paragraph and table spacing at bottom of table cells

Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph in
a table cell.

Use as Default button
Click this button to use the current settings on this page as the default in OpenOffice.org.

AutoCaption options

Do you want OOo to automatically insert captions for tables, pictures, frames, and OLE
objects that have been inserted in a Writer document?

Note You may not always want captions for every table, for example, if you use tables for
layout as well as for tables of data. You can always add captions to individual tables,
graphics, or other objects (right-click > Caption).

If you do want automatic captions on one or more object types:
1) Choose OpenOffice.org Writer > AutoCaption on the Options dialog box.

2) On the OpenOffice.org Writer — AutoCaption page (Figure 27), select the checkbox next
to an object you want to be automatically captioned (Picture in the example shown).

3) With the item highlighted, specify the characteristics of the caption. The supplied
categories for captions are Drawing, Illustration, Table, and Text. However, you are
not limited to the supplied categories. If you want to use another name (for example,
Figure) for the caption label, type the required term in the box. In the example shown, I
have added the category “Figure” to the list.

For more information about numbering captions by chapter, character styles, frame styles, and
other items on the AutoCaption page, see other chapters in the Writer Guide.
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Add captions automatically Caption

when ingerting: Category
[ OpenOffice.org Writer Table Mumbering Arabic (12 3) hd
r OpenQffice. org Writer Frame

[v OpenOffice.org Writer Picture Separator

[ OpenOffice.org Spreadshest »

[~ Cpenoffice.org Chart Position Belo

r OpenOffice.org Drawing

|_ OpenOffice. org Presentation
OpenQffice, org Formula Level 1 "

[T Other OLE Objects

Mumbering captions by chapter

Separator
Category and frame format
Character style Maone »

[ ] Apply border and shadow

Figure 1:

Figure 27. Setting up a new category for automatic captions on graphics

Mail Merge E-mail options

You can produce form letters using Writer and then use the mail merge function to personalize
those letters and send them to a number of addresses taken from a data source, such as an
address book. Mail merged documents can be printed and mailed, or sent by e-mail.

Use the Options — OpenOffice.org Writer — Mail Merge E-mail page (Figure 28) to set up the
user and server information for sending form letters by e-mail. If you are not sure what
information to put in any of the fields, consult your e-mail program or your Internet service
provider.

IJser information

Your name
E-Mail address

[ ] send replies to different e-mail address

QOutgeing server (SMTF) Settings

Server name Port | 25

[ ] U=ze secure connection {S5L)

[ Server Authentication ]

[ Test Settings... ]

Figure 28: Specifying settings for use when e-mailing mail-merged form letters
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Choosing language settings

You may need to do several things to set the language settings to what you want:
Install the required dictionaries
Change some locale and language settings

Choose spelling options

Install the required dictionaries

OpenOffice.org 2.0 and later versions automatically install several dictionaries with the
program. To add other dictionaries, use File > Wizards > Install new dictionaries. An OOo
document will open with links to different languages that you can install. Follow the prompts
to install them.

Change some locale and language settings

You can change some details of the locale and language settings that OOo uses for all
documents or for specific documents.

-

Options - Language Settings

QpenQffice.org

Load/Save s :
Bl fanquage Setfings AN SIS T
Languages
Writing Aids
OpenOffice.arg Writer This is where you make settings concerning language and v
OpenOffice.org Writer \Mieb OpenOffice.org.

F ig;re 29: OpenOffice.org Language Options

1) In the Options dialog box, click Language Settings > Languages.

2) On the right-hand side of the Language Settings — Languages page (Figure 30), change
the User interface, Locale setting, Default currency, and Default languages for
documents as required. In the example, English (UK) has been chosen for all the
appropriate settings.

3) If you want the language (dictionary) setting to apply to the current document only,
instead of being the default for all new documents, select the checkbox labeled For the
current document only.

4) If necessary, select the checkboxes to enable support for Asian languages (Chinese,
Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi,
Thai, Hebrew, and Arabic. If you choose either of these checkboxes, the next time you
open this page, you will see some extra choices under Language Settings, as shown in
Figure 31. These choices (Searching in Japanese, Asian Layout, and Complex Text
Layout) are not discussed here.

5) Click OK to save your changes and close the dialog box.
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Language of

User interface
Locale setting
Decimal separataor key

Default currency

(English (UK)

(]

English (UK)

(]

Same a5 locale setting (. )

\GBP £ Engish (UK)

(]

Default languages for documents

Western |H$ English (LK) M|
Aslan | |
L | |

[ ] For the current document only

Enhanced language support
[] Enabled for Asian languages
[ ] Enabled for complex text layout (CTL)
Figure 30. Choosing language options

Note If you need to use non-Western languages, and especially if you need to use more than
one non-Western language in the same document, refer to the tutorial, “OOo in a
Multi-Lingual Environment.”

Language of

User interface |English (LK) Ml
Locale setting (English (UK) ]|
Decmal separator key Same as locale setting (. )

Default currency |GBF‘ £ English {UK) &"

Default languages for documents

Western |H$ English {LK) &"
Asian | Ml
L | ]

[ ] For the current document only

Enhanced language support
Enabled for Asian languages

Enabled for complex text layout {CTL)

Figure 31. Extra setting choices when enhanced language support options are
selected
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Choose spelling options

To choose the options for checking spelling:
1) In the Options dialog box, click Language Settings > Writing Aids.

2) In the Options section of the Language Settings — Writing Aids page (Figure 32), choose
the settings that are useful for you. Some considerations:

- If you don’t want spelling checked while you type, deselect Check spelling as you
type and select Do not mark errors. (To find the second item, scroll down in the
Options list.)

« Ifyou use a custom dictionary that includes words in all uppercase and words with
numbers (for example, AS/400), select Check uppercase words and Check words
with numbers.

+ Check special regions includes headers, footers, frames, and tables when checking
spelling.

+ Here you can also check which of the user-defined (custom) dictionaries are active,
or you can add or remove dictionaries by clicking the New or Delete buttons.

Writing aids
Available language modules

¥ OpenOffice.org Hunspell SpellChecker Edit
[w aLTLinux LibHnj Hyphenator
¥ CpenOffice.org New Thesaurus

IUser-defined dictionaries

[w standard [Al] M
[w soffice [All

[w sun [Al]

Iw IgnoreallList [All]

L=k
Edit...

Delete

tions

I3

Check spelling as you type ~
Check uppercase words
Check words with numbers
Check capitalisation

Check spedial regions

o P PO JUN | [ P p—p——

v

IEEUREREY

Figure 32. Choosing languages, dictionaries, and options for checking spelling

Setting up Writer 28



Controlling Writer’s AutoCorrect functions

Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer’s AutoCorrect feature annoying because
they change what you type when you don’t want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant checkboxes. But if you
find unexplained changes appearing in your document, this is a good place to look to find the

causc.

To open the AutoCorrect dialog box, click Tools > AutoCorrect/AutoFormat. (You need to
have a document open for this menu item to appear.)

In Writer, this dialog box has five tabs, as shown in Figure 33.

-

AutoCorrect

-y

Replace || Exceptions |Options | Custom Quotes || Word Completion

IR IKIRIRES S
B A A i A A A R EA A Ak =

<1

IUse replacement table

Correct TWao IMitial CApitals

Capitalise first letter of every sentence
Automatic *bold™ and _underline_

URL Recognition

Replace 1st... with 1st...

Replace 1/2 ... with 2.,

Replace dashes

Delete spaces and tabs at beginning and end of paragraph
Delete spaces and tabs at end and start of line
Ignore double spaces

Apply numbering - symbaol: =

Apply border

Create table

Apply Styles

Remove blank paragraphs

Replace Custom Stvles

[M]: Replace while modifying existing text
[T]: AutoFormatfAutoCarrect while typing

[ Ok, H Cancel H

Help

H Reset ]

Figure 33. The AutoCorrect dialog box in Writer, showing the five tabs and some of
the choices on the Options tab
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